Mise à jour de PluXml (vers la version 5.5)

Rédigé par Alain Olivetti - -
Après une réinstallation de mon système, passant ainsi de debian jessie à debian stretch, j'ai rencontré des problèmes pour remettre en fonction mon site sous PluXml (nginx+php5-fpm).
Après pas mal de problème/analyse des logs/recherche sur internet j'ai finalement réussi à le remettre en fonction.
La difficulté provenais du fait que j'espérais simplement transférer mon ancien site et ancienne configuration de nginx+php5-fpm... Oui mais c'est maintenant php7.0 qui est utilisé !
Voila les deux choses que j'ai du faire:
  • Modifier un fichier de configuration de nginx pour changer le lien entre nginx et php-fpm. Pour cela dans les environnements server->location j'ai remplacé la ligne commençant par ``fastcgi_pass'' avec: fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
  • Penser à installer le paquet : php7.0-xml.